The W
Views: 100884452
Main | FAQ | Search: Y! / G | Calendar | Color chart | Log in for more!
26.11.14 1821
The W - the-w.com Site Feedback - Request for The 7
This thread has 5 referrals leading to it
Register and log in to post!
Thread rated: 5.82
Pages: 1
(243 newer) Next thread | Previous thread
User
Post (7 total)
TheBucsFan
TheChiefsFan








Since: 2.1.02

Since last post: 106 days
Last activity: 106 days
#1 Posted on | Instant Rating: 2.23
When I'm looking in the "see all new posts in this forum" view, I don't see the reply, quote, etc buttons. I have to click into the thread to post. I don't know if it's like this for the other views. Is this on purpose?
Promote this thread!
CRZ
Big Brother
Administrator








Since: 9.12.01
From: ミネアポリス

Since last post: 2 hours
Last activity: 1 hour
AIM:  
ICQ:  
Y!:
#2 Posted on | Instant Rating: 8.51
    Originally posted by TheBucsFan
    When I'm looking in the "see all new posts in this forum" view, I don't see the reply, quote, etc buttons. I have to click into the thread to post. I don't know if it's like this for the other views. Is this on purpose?
You should ALWAYS see a reply link on EVERY post on The 7 ALL the time because we have no expiration on threads over there. (You can even reply to yourself!)

Can you give throw me a link with an example? I must not be properly recreating your situation, because I'm seeing reply links everywhere.



TheBucsFan
TheChiefsFan








Since: 2.1.02

Since last post: 106 days
Last activity: 106 days
#3 Posted on | Instant Rating: 2.23
    Originally posted by CRZ
      Originally posted by TheBucsFan
      When I'm looking in the "see all new posts in this forum" view, I don't see the reply, quote, etc buttons. I have to click into the thread to post. I don't know if it's like this for the other views. Is this on purpose?
    You should ALWAYS see a reply link on EVERY post on The 7 ALL the time because we have no expiration on threads over there. (You can even reply to yourself!)

    Can you give throw me a link with an example? I must not be properly recreating your situation, because I'm seeing reply links everywhere.


This link, for example, gives me all the "new" posts in Site Bashing, but I don't have reply links.

EDIT: Upon further inspection, I only am missing the "Reply" link in the top three threads in the "new" posts view. Posts in the lower threads have the reply link. It's the same way when I click on the link again in other forums.

(edited by TheBucsFan on 2.5.09 0111)

(edited by TheBucsFan on 2.5.09 0112)
CRZ
Big Brother
Administrator








Since: 9.12.01
From: ミネアポリス

Since last post: 2 hours
Last activity: 1 hour
AIM:  
ICQ:  
Y!:
#4 Posted on | Instant Rating: 8.51
    Originally posted by TheBucsFan
      Originally posted by CRZ
        Originally posted by TheBucsFan
        When I'm looking in the "see all new posts in this forum" view, I don't see the reply, quote, etc buttons. I have to click into the thread to post. I don't know if it's like this for the other views. Is this on purpose?
      You should ALWAYS see a reply link on EVERY post on The 7 ALL the time because we have no expiration on threads over there. (You can even reply to yourself!)

      Can you give throw me a link with an example? I must not be properly recreating your situation, because I'm seeing reply links everywhere.


    This link, for example, gives me all the "new" posts in Site Bashing, but I don't have reply links.

    EDIT: Upon further inspection, I only am missing the "Reply" link in the top three threads in the "new" posts view. Posts in the lower threads have the reply link. It's the same way when I click on the link again in other forums.

    (edited by TheBucsFan on 2.5.09 0111)

    (edited by TheBucsFan on 2.5.09 0112)
I think I've finally figured it out. The ones where you're not seeing the link must be over a week old, and there must be some expiration check still working in there I forgot to take out. I'll find it and fix it.



TheBucsFan
TheChiefsFan








Since: 2.1.02

Since last post: 106 days
Last activity: 106 days
#5 Posted on | Instant Rating: 2.23
Also on the 7:

Why are there so many posts that seem to get duplicated? For example, here I see the same tomvejada post *10* straight times. And as was illustrated in a threat in the 7, it isn't always that way in the thread in real time.
CRZ
Big Brother
Administrator








Since: 9.12.01
From: ミネアポリス

Since last post: 2 hours
Last activity: 1 hour
AIM:  
ICQ:  
Y!:
#6 Posted on | Instant Rating: 8.51
    Originally posted by TheBucsFan
    Also on the 7:

    Why are there so many posts that seem to get duplicated? For example, here I see the same tomvejada post *10* straight times. And as was illustrated in a threat in the 7, it isn't always that way in the thread in real time.
I know WHY this happens (some bot or spider hits The 7 several times within milliseconds while we're trying to inject a "new" post, resulting in more than one injection of that same post), but I haven't figured out a good way to fix this and still accomplish semi-real-time updatery. I try to ferret out the dupes and blow them away when it gets redonkulous. It's on my list of things to do, just at a lower priority, like a lot of stuff 7-side.



CRZ
Big Brother
Administrator








Since: 9.12.01
From: ミネアポリス

Since last post: 2 hours
Last activity: 1 hour
AIM:  
ICQ:  
Y!:
#7 Posted on | Instant Rating: 8.51
    Originally posted by CRZ
      Originally posted by TheBucsFan
      Also on the 7:

      Why are there so many posts that seem to get duplicated? For example, here I see the same tomvejada post *10* straight times. And as was illustrated in a threat in the 7, it isn't always that way in the thread in real time.
    I know WHY this happens (some bot or spider hits The 7 several times within milliseconds while we're trying to inject a "new" post, resulting in more than one injection of that same post), but I haven't figured out a good way to fix this and still accomplish semi-real-time updatery. I try to ferret out the dupes and blow them away when it gets redonkulous. It's on my list of things to do, just at a lower priority, like a lot of stuff 7-side.
I think I fixed this. The process that updates our newsfeeds when new threads are created is taking a bit longer due to the new way I'm tagging them (using their icon if there is one, and their forum if there isn't) so I added some locking/unlocking to the OTHER process that checks whether it's time to inject a new post into The 7 yet. Nobody cares about what I just said, but you WILL care that there shouldn't be 17 copies of the first post of a thread showing up on The 7 anymore.



Thread rated: 5.82
Pages: 1
Thread ahead: New Posts not displaying when you enter topic
Next thread: Huge delays when posting new threads
Previous thread: "View posts by user"
(243 newer) Next thread | Previous thread
Is anyone else using Apple's new browser, Safari? I can't seem to log in here using it.
- The Sham, Safari and the Wienerboard (2003)
The W - the-w.com Site Feedback - Request for The 7Register and log in to post!

The W™ message board

ZimBoard
©2001-2014 Brothers Zim

This old hunk of junk rendered your page in 0.155 seconds.